4.某公司建立局域网拓扑图如图4-1所示。公司计划使用路由器作为DHCP服务器,根据需求,公司内部使用C类地址段,服务器地址段为192.168.2.0/24,S2和S3分别为公司两个部门的接入交换机,分别配置VLAN 10和VLAN 20,地址段分别使用192.168.10.0/24和192.168.20.0/24,通过DHCP服务器自动为两个部门分配IP地址,地址租约期为12小时。其中,192.168.10.1~192.168.10.10作为保留地址。
图4-1
【问题1】(10分,每空1分)
下面是R1的配置代码,请将下面配置代码补充完整。
R1#config t
R1(config)#interface FastEthernet0/0
R1(config-if)#ip address(1)(2)
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip dhcp(3)depart1
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.10.254 255.255.255.0
R1(dhcp-config)#dns-server(4)
R1(dhcp-config)#lease 0(5)0
R1(dhcp-config)#exit
R1(config)#ip dhcp pool depart2
R1(dhcp-config)#network(6)(7)
R1(dhcp-config)#default-router 192.168.20.254 255.255.255.0
R1(dhcp-config)#dns-server 192.168.2.253
R1(dhcp-config)#lease 0 12 0
R1(dhcp-config)#exit
R1(config)#ip dhcp excluded-address(8)(9)
R1(config)#ip dhcp excluded-address(10)//排除掉不能分配的IP地址
R1(config)#ip dhcp excluded-address 192.168.20.254
......
【问题2】(5分,每空1分)
下面是S1的配置代码,请将下面配置代码或解释补充完整。
S1#config terminal
S1(config)#interface vlan 5
S1(config-if)#ip address 192.168.2.254 255.255.255.0
S1(config)#interface vlan 10
S1(config-if)#ip helper-address(11)∥指定DHCP服务器的地址
S1(config-if)#exit
S1(config)#interface vlan 20
......
S1(config)#interface f0/24
S1(config-if)#switchport mode(12)
S1(config-if)#switchport trunk(13)vlan all∥允许所有VLAN数据通过
S1(config-if)#exit
S1(config)#interface f0/21
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 5
S1(config-if)#exit
S1(config)#interface f0/22
S1(config-if)#switchport mode access
S1(config-if)#switchport access(14)
S1(config)#interface f0/23
S1(config-if)#switchport mode access
S1(config-if)#switchport access(15)